Error upgrading from 47 to 53

I tried both ways, run the installer or extract zip over previous install.
I receive this error message:
Unsupported major.minor version 52.0

Foren
AS2

Comments

LINUX.
The classpath is:
as2.jar:jetty9/start.jar:jlib/bcmail-jdk15on-158.jar:jlib/bcpkix-jdk15on-158.jar:jlib/bcprov-jdk15on-158.jar:jlib/commons-dbcp2-2.1.1.jar:jlib/commons-io-2.5.jar:jlib/commons-pool2-2.4.2.jar:jlib/hsqldb.jar:jlib/javamail-1.5.6.jar:jlib/jaxen-1.1.3.jar:jlib/jcalendar-1.3.3.jar:jlib/jcalendar-looks-2.0.1.jar:jlib/l2fprod-common-all.jar:jlib/mina/log4j-1.2.17.jar:jlib/mina/mina-core-2.0.16.jar:jlib/mina/slf4j-api-1.7.5.jar:jlib/mina/slf4j-log4j12-1.7.5.jar:jlib/jpod/iscwt.jar:jlib/jpod/isrt.jar:jlib/jpod/jbig2.jar:jlib/jpod/jPod.jar:jlib/help/help-share.jar:jlib/help/jewt.jar:jlib/help/ohj.jar:jlib/help/oracle_ice.jar:jlib/help/share.jar:jlib/vaadin/vaadin-6.7.10.jar:jetty9/lib/annotations-api.jar:jetty9/lib/asm-5.0.3.jar:jetty9/lib/jetty-alpn-client-9.2.4.v20141103.jar:jetty9/lib/jetty-alpn-client-9.2.9.v20150224.jar:jetty9/lib/jetty-alpn-server-9.2.4.v20141103.jar:jetty9/lib/jetty-alpn-server-9.2.9.v20150224.jar:jetty9/lib/jetty-annotations-9.2.4.v20141103.jar:jetty9/lib/jetty-annotations-9.2.9.v20150224.jar:jetty9/lib/jetty-cdi-9.2.4.v20141103.jar:jetty9/lib/jetty-cdi-9.2.9.v20150224.jar:jetty9/lib/jetty-client-9.2.9.v20150224.jar:jetty9/lib/jetty-continuation-9.2.4.v20141103.jar:jetty9/lib/jetty-continuation-9.2.9.v20150224.jar:jetty9/lib/jetty-deploy-9.2.4.v20141103.jar:jetty9/lib/jetty-deploy-9.2.9.v20150224.jar:jetty9/lib/jetty-http-9.2.4.v20141103.jar:jetty9/lib/jetty-http-9.2.9.v20150224.jar:jetty9/lib/jetty-io-9.2.4.v20141103.jar:jetty9/lib/jetty-io-9.2.9.v20150224.jar:jetty9/lib/jetty-jaas-9.2.4.v20141103.jar:jetty9/lib/jetty-jaas-9.2.9.v20150224.jar:jetty9/lib/jetty-jaspi-9.2.9.v20150224.jar:jetty9/lib/jetty-jmx-9.2.9.v20150224.jar:jetty9/lib/jetty-jndi-9.2.4.v20141103.jar:jetty9/lib/jetty-jndi-9.2.9.v20150224.jar:jetty9/lib/jetty-plus-9.2.4.v20141103.jar:jetty9/lib/jetty-plus-9.2.9.v20150224.jar:jetty9/lib/jetty-proxy-9.2.4.v20141103.jar:jetty9/lib/jetty-proxy-9.2.9.v20150224.jar:jetty9/lib/jetty-quickstart-9.2.9.v20150224.jar:jetty9/lib/jetty-rewrite-9.2.4.v20141103.jar:jetty9/lib/jetty-rewrite-9.2.9.v20150224.jar:jetty9/lib/jetty-schemas-3.1.jar:jetty9/lib/jetty-security-9.2.4.v20141103.jar:jetty9/lib/jetty-security-9.2.9.v20150224.jar:jetty9/lib/jetty-server-9.2.4.v20141103.jar:jetty9/lib/jetty-server-9.2.9.v20150224.jar:jetty9/lib/jetty-servlet-9.2.4.v20141103.jar:jetty9/lib/jetty-servlet-9.2.9.v20150224.jar:jetty9/lib/jetty-servlets-9.2.4.v20141103.jar:jetty9/lib/jetty-servlets-9.2.9.v20150224.jar:jetty9/lib/jetty-util-9.2.4.v20141103.jar:jetty9/lib/jetty-util-9.2.9.v20150224.jar:jetty9/lib/jetty-webapp-9.2.4.v20141103.jar:jetty9/lib/jetty-webapp-9.2.9.v20150224.jar:jetty9/lib/jetty-xml-9.2.4.v20141103.jar:jetty9/lib/jetty-xml-9.2.9.v20150224.jar:jetty9/lib/servlet-api-3.1.jar:jlib/httpclient/commons-codec-1.9.jar:jlib/httpclient/commons-logging-1.2.jar:jlib/httpclient/fluent-hc-4.5.jar:jlib/httpclient/httpclient-4.5.jar:jlib/httpclient/httpclient-cache-4.5.jar:jlib/httpclient/httpcore-4.4.1.jar:jlib/httpclient/httpmime-4.5.jar

the error is this one:
java.lang.UnsupportedClassVersionError: org/hsqldb/jdbcDriver : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:442)
at java.net.URLClassLoader.access$100(URLClassLoader.java:64)
at java.net.URLClassLoader$1.run(URLClassLoader.java:354)
at java.net.URLClassLoader$1.run(URLClassLoader.java:348)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:347)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:312)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:195)
at de.mendelson.comm.as2.database.DBDriverManager.registerDriver(DBDriverManager.java:41)
at de.mendelson.comm.as2.AS2.main(AS2.java:103)